FAQ

Labelcall for Android is compatible with smartphones running Android 4.1 and up.

Currently, Apple does not provide the technical background necessary to create the application compatible with their system but as soon as it changes, we’ll definitely create such a version.

There are three simple steps:
Visit widget issue page and follow the instructions given on the website.
We’re available in various channels to meet your needs. Reach out to us by the form available at contact page. You can also find us on your favorite social media platforms, write us a message via our Facebook profile.